bootstrapping from svn

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

bootstrapping from svn

David Emerson
Well, I decided to make another attempt at running from the svn
fixes_2_6 branch

The first problem I encountered was that I could not compile from fpc 2.4.4.

It sure would be nice if a compatible ppc386 executable was included in
the repository, so I wouldn't have to go download it from somewhere else.

Thoughts?
~David

(Graeme, if you read this, have you considered creating a git branch for
the 2.6 fixes branch?)


_______________________________________________
fpc-pascal maillist  -  [hidden email]
http://lists.freepascal.org/mailman/listinfo/fpc-pascal
Reply | Threaded
Open this post in threaded view
|

Re: bootstrapping from svn

leledumbo
Administrator
2.6(.1) fixes should be compilable only from 2.6.0
Reply | Threaded
Open this post in threaded view
|

Re: bootstrapping from svn

Reinier Olislagers
In reply to this post by David Emerson


On 26-11-2012 2:27, David Emerson wrote:
> It sure would be nice if a compatible ppc386 executable was included in
> the repository, so I wouldn't have to go download it from somewhere else.
>
> Thoughts?
For many architectures, there is a bootstrap 2.6 compiler available from
SVN. Just a different URL though (don't know it by heart).


_______________________________________________
fpc-pascal maillist  -  [hidden email]
http://lists.freepascal.org/mailman/listinfo/fpc-pascal
Reply | Threaded
Open this post in threaded view
|

Re: bootstrapping from svn

patspiper
In reply to this post by leledumbo
On 26/11/12 08:09, leledumbo wrote:
> 2.6(.1) fixes should be compilable only from 2.6.0
Bootstrap compiler 2.6.0:
ftp://ftp.hu.freepascal.org/fpc/dist/2.6.0/bootstrap/
_______________________________________________
fpc-pascal maillist  -  [hidden email]
http://lists.freepascal.org/mailman/listinfo/fpc-pascal
Reply | Threaded
Open this post in threaded view
|

Re: bootstrapping from svn

Mark Morgan Lloyd-5
In reply to this post by David Emerson
David Emerson wrote:
> Well, I decided to make another attempt at running from the svn
> fixes_2_6 branch
>
> The first problem I encountered was that I could not compile from fpc
> 2.4.4.
>
> It sure would be nice if a compatible ppc386 executable was included in
> the repository, so I wouldn't have to go download it from somewhere else.

What is your problem with starting at
http://www.freepascal.org/download.var ?

--
Mark Morgan Lloyd
markMLl .AT. telemetry.co .DOT. uk

[Opinions above are the author's, not those of his employers or colleagues]
_______________________________________________
fpc-pascal maillist  -  [hidden email]
http://lists.freepascal.org/mailman/listinfo/fpc-pascal
Reply | Threaded
Open this post in threaded view
|

Re: bootstrapping from svn

Graeme Geldenhuys-3
In reply to this post by David Emerson
On 26/11/12 01:27, David Emerson wrote:
>
> (Graeme, if you read this, have you considered creating a git branch for
> the 2.6 fixes branch?)

I decided against tracking the fixes branches after I realised what
strange way the FPC team manages tags, branches etc in SubVersion. After
attempting to track the 2.4.x fixes branch (at that time), it was simply
too much work for me, because it wasn't an automated process (so I could
optimise the size of the repository).

You can simply do a

   git svn clone -r1234:HEAD http://....

where r1234 is the revision you want to start from (thus limiting the
amount of history you pull in). Replace r1234 with your own starting
revision.


Regards,
  - Graeme -

--
fpGUI Toolkit - a cross-platform GUI toolkit using Free Pascal
http://fpgui.sourceforge.net/

_______________________________________________
fpc-pascal maillist  -  [hidden email]
http://lists.freepascal.org/mailman/listinfo/fpc-pascal
Reply | Threaded
Open this post in threaded view
|

Re: bootstrapping from svn

babynancy543
This post has NOT been accepted by the mailing list yet.
In reply to this post by David Emerson
Your computer is having trouble running the game's opening video.

Try updating your graphics drivers.








get facebook fans