aterm won't run fp

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

aterm won't run fp

John Coppens
Hi all

Even though I don't have a solution to the previous problem, I already
have another one.

A while ago I tried 'fp' and didn't get anything. Not having time, I
dropped the issue. Now I tried again, and decided to dig a little deeper:

1) in an 'aterm', calling fp doesn't show _anything_, just waits for
Ctrl-C to exit to the promps (no menu, no gibberish.)

2) in a real 'xterm', fp works normally - I don't like xterms, because I
had some problems with multiple charsets and I haven't found out to make
them transparent.

3) I tried with 'aterm --font vga', then start fp - exactly the same. The
font changed to vga though, but no fp in sight. Tried several other
fonts, switched off 'aterm' transparence, just in case.

4) Also tried to add -tn linux, though that's the default.

Can anyone tell me what's missing to get aterm to run fp?

Thanks,
John
_______________________________________________
fpc-pascal maillist  -  [hidden email]
http://lists.freepascal.org/mailman/listinfo/fpc-pascal
Reply | Threaded
Open this post in threaded view
|

Re: aterm won't run fp

Marco van de Voort
> Can anyone tell me what's missing to get aterm to run fp?

Implementation of the Xterm terminal standard ? :)

Debugging startup (possibly using a simpler example like installer first),
is the only real solution I think.
_______________________________________________
fpc-pascal maillist  -  [hidden email]
http://lists.freepascal.org/mailman/listinfo/fpc-pascal
Reply | Threaded
Open this post in threaded view
|

Re: aterm won't run fp

John Coppens
On Tue, 25 Apr 2006 08:52:05 +0200 (CEST)
[hidden email] (Marco van de Voort) wrote:

> > Can anyone tell me what's missing to get aterm to run fp?
>
> Implementation of the Xterm terminal standard ? :)
>
> Debugging startup (possibly using a simpler example like installer
> first), is the only real solution I think.

Just in case someone bumps into the same problem - Thanks to some
suggestions on the IRC channel, I solved the aterm problem with:

aterm -tn xterm -e fp

Surprisingly 'aterm -tn rxvt -e fp' does not work (but rxvt -e fp does
work!)

John
_______________________________________________
fpc-pascal maillist  -  [hidden email]
http://lists.freepascal.org/mailman/listinfo/fpc-pascal
Reply | Threaded
Open this post in threaded view
|

Re: aterm won't run fp

Micha Nelissen
On Wed, 3 May 2006 01:42:23 -0300
John Coppens <[hidden email]> wrote:

> aterm -tn xterm -e fp
>
> Surprisingly 'aterm -tn rxvt -e fp' does not work (but rxvt -e fp does
> work!)

That's a bug in aterm then. Either it should implement all of the rxvt
terminal escapes, or use it's own terminal type.

Micha
_______________________________________________
fpc-pascal maillist  -  [hidden email]
http://lists.freepascal.org/mailman/listinfo/fpc-pascal