What should I use for ARM EABI?

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

What should I use for ARM EABI?

josepascual (almudi)
Hi everyone,

I can build fpc for arm 2.2 (ver 2.1.5) and I can build 2.3.1 for with "-Ce
-CfSOFT" options.

I have a board with a ARM EABI systems, and I'd like to develop some
programs with freepascal for ARM.

Which should I use 2.2_beta or 2.3.1?
Is softfloat implemented in both solution? or more implemented in 2.3.1?
I supose 2.2_beta is more stable than 2.3.1? or both version are stables in
the same way?

thank you

Jose Pascual


_______________________________________________
fpc-pascal maillist  -  [hidden email]
http://lists.freepascal.org/mailman/listinfo/fpc-pascal
Reply | Threaded
Open this post in threaded view
|

Re: What should I use for ARM EABI?

Henry Vermaak
On 16/07/07, josepascual <[hidden email]> wrote:

> Hi everyone,
>
> I can build fpc for arm 2.2 (ver 2.1.5) and I can build 2.3.1 for with "-Ce
> -CfSOFT" options.
>
> I have a board with a ARM EABI systems, and I'd like to develop some
> programs with freepascal for ARM.
>
> Which should I use 2.2_beta or 2.3.1?
> Is softfloat implemented in both solution? or more implemented in 2.3.1?
> I supose 2.2_beta is more stable than 2.3.1? or both version are stables in
> the same way?
>

i see from the logs that yuri has been fixing some arm bugs.  i don't
know if they are merged yet, so i guess you should use the trunk for
now.  if they get merged you can use 2.2 after the release to ensure
stability.  just check mantis...

henry
_______________________________________________
fpc-pascal maillist  -  [hidden email]
http://lists.freepascal.org/mailman/listinfo/fpc-pascal