Patch to add GLX 1.4 support

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Patch to add GLX 1.4 support

Michalis Kamburelis-3
Hi,

For people working with new OpenGL features: I just submitted a patch
to upgrade our GLX unit to GLX 1.4, add some new GLX extensions, and
add comfortable functions to check existence of a particular GLX
extension/version. This allows you to easily use modern GLX "FB
config" functions to initialize OpenGL context, and to use
glXCreateContextAttribsARB to request forward-compatible OpenGL
context (without deprecated stuff). The patch is on

http://bugs.freepascal.org/view.php?id=19953

The patch contains also modifications to glxtest example, to show new
context creation approach. There's a good description of modern OpenGL
context creation in the opengl.org wiki, see
http://www.opengl.org/wiki/Creating_an_OpenGL_Context and
http://www.opengl.org/wiki/Tutorial:_OpenGL_3.0_Context_Creation_%28GLX%29

Michalis
_______________________________________________
fpc-pascal maillist  -  [hidden email]
http://lists.freepascal.org/mailman/listinfo/fpc-pascal